0712-2888027 189-8648-0214
微信公众号

孝感风信网络科技有限公司微信公众号

当前位置: 主页 > 技术支持 > PHP > Laravel中使用overtrue/laravel-wechat微信SDK安装与配置

Laravel中使用overtrue/laravel-wechat微信SDK安装与配置

时间:2017-11-01来源:风信网 点击:
安装overtrue/laravel-wechat包,可以从https://packagist.org/packages/overtrue/laravel-wechat以下地址获取:

composer require "overtrue/laravel-wechat:~3.1"

注册ServiceProvider:在config下的app.php中的 providers 数组中添加:

Overtrue\LaravelWechat\ServiceProvider::class,

创建配置文件:在命令行中执行

php artisan vendor:publish --provider="Overtrue\LaravelWechat\ServiceProvider"

D:\phpStudy\Laravel5.5>php artisan vendor:publish --provider="Overtrue\LaravelWechat\ServiceProvider"

Copied File [\vendor\overtrue\laravel-wechat\src\config.php] To [\config\wechat.php]
Publishing complete.

提示成功,成功之后会在config文件夹下生成wechat.php文件,修改对应的参数

/*
* 账号基本信息,请从微信公众平台/开放平台获取
*/
'app_id'  => env('WECHAT_APPID', 'your-app-id'),         // AppID
'secret'  => env('WECHAT_SECRET', 'your-app-secret'),     // AppSecret
'token'   => env('WECHAT_TOKEN', 'your-token'),          // Token
'aes_key' => env('WECHAT_AES_KEY', ''),                    // EncodingAESKey

如果执行该命令后显示已发布但是在config中找不到配置文件的话,看一下 config/app.php  

providers数组中是否有

Laravel中使用overtrue/laravel-wechat微信SDK安装与配置

如果有的话将其先注释掉,重新执行上面发布服务的命令,即可生成配置文件 config/wechat.php,如果需要使用到 laravel\thinker的话,生成配置文件以后,将刚刚注释的还原

D:\phpStudy\Laravel5.5>php artisan vendor:publish --provider="Overtrue\LaravelWe
Chat\ServiceProvider"

 [Symfony\Component\Debug\Exception\FatalErrorException]
Class 'Overtrue\LaravelWeChat\ServiceProvider' not found

如遇到这个问题,可执行以下composer dump-autoload,问题得到解决。
热门关键词:Laravel安装配置微信SDK
栏目列表
推荐内容
热点内容
展开